Grub désactivé après chaque démarrage Windows Le sujet est résolu

Demande d'aide : c'est ici.
Répondre
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

Bonjour la communauté,

J'ai reçu un Sony VAIO (SVF152C29M). J'ai supprimé toutes les partitions, j'y ai mis une nouvelle version Windows 10 via USB, ensuite j'ai installé Debian toujours via USB. Le grub s'est bien installé. J'ai testé le démarrage windows, plus de grub au redémarrage. J'ai réinstallé le grub (via rescatux), debian est de nouveau accessible. Je redémarre sous windows et rebelote.
Voici la liste de mes partitions, où sda5 correspond à la partition boot:
/dev/sda1: UUID="C015-22D8" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e6735d3f-36cb-4f39-b4b3-bb6bdcb15163"
/dev/sda3: BLOCK_SIZE="512" UUID="1A341B23341B0185" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b58a7ef0-03c9-4f49-8fb8-11814f7e3b47"
/dev/sda4: BLOCK_SIZE="512" UUID="A6DC5B33DC5AFCCD" TYPE="ntfs" PARTUUID="f6fb09c3-44ad-436b-9a08-f731334b8496"
/dev/sda5: UUID="c9ad51f6-6256-4b44-bde3-1b96a65c05a5" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="c70ab307-eb7a-4a6b-9a6b-c28924c32804"
/dev/sda6: UUID="74774e3d-ac6a-4666-b88b-7e87d01fd628" TYPE="swap" PARTUUID="524c1d78-5450-43c6-ab2f-0c45e85ec616"
/dev/sda7: UUID="1524bfa3-9a9d-42d9-8607-7ba6e25c26fa" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="b105ef16-46b8-4ecd-9921-4b26920bb5ae"
/dev/sda8: UUID="9bdd7240-7654-4f39-a627-de7e9d1801a9" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="e7b9888a-fbeb-43f4-b565-5a03fb6efff4"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="12232efd-2654-478d-9bb6-4087bf116a0c"
A bientôt

o/
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2331
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

Bonjour et Bienvenue ici.

Pendant la phase de partitionnement de l'installation de Debian, la partition N°1 :

/dev/sda1: UUID="C015-22D8" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e6735d3f-36cb-4f39-b4b3-bb6bdcb15163"

a-t-elle été indiquée comme ESP (usage) ?

Normalement après installation, le fichier : /etc/fstab
devrait contenir quelque-chose comme :

Code : Tout sélectionner

# /boot was on /dev/sda5 during installation
UUID=c9ad51f6-6256-4b44-bde3-1b96a65c05a5 /boot           ext4   defaults        0       2

# /boot/efi was on /dev/sda1 during installation
UUID=C015-22D8  /boot/efi       vfat    -------     0       1

Que renvoie la commande : cat /etc/fstab


Noter que GRUB sait lire les partitions avant le démarrage et qu'il ne les monte pas,
mais je pense que l'état du fstab devrait refléter comment l'installation a été faite.
Debian stable - XFCE
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

Rebonjour,

Merci pour ton aide.

Pour ce qui concerne l'ESP, je n'en sais rien. J'avoue que je n'ai jamais eu besoin de bien comprendre l'UEFI jusqu'ici.

Code : Tout sélectionner

# /boot was on /dev/sda5 during installation
UUID=c9ad51f6-6256-4b44-bde3-1b96a65c05a5 /boot           ext4    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=C015-22D8  /boot/efi       vfat    umask=0077      0       1
A bientôt
Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 4042
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Bonjour,
afin d'éviter ce genre de désagrément, j'applique une solution radicale.
Je n'installe que debian comme distribution de base. Le windows est installé dans une machine virtuelle kvm.
Tout dépends de ton usage de windows, cela peut créer des limitation mais tu as toujours la possibilité de lui donner accès directement au matériel. Par exemple lui donner un accès direct à la carte graphique si besoin (jeu performant, montage vidéo ...)
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2331
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

Avant d'en arriver à une solution aussi radicale que celle de piratebab ou pire la mienne => Oublie Win :lol:

Tu peux tester de réinstaller GRUB depuis Debian installé avec :

Code : Tout sélectionner

$ su -
# cp /boot/grub/grub.cfg /boot/grub/grub.cfg.orig
# update-grub
# grub-install
# exit
... renvoies-nous la sortie si elle contient des messages d'erreur.
Debian stable - XFCE
Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 3952
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Status : Hors-ligne

Salut,

Le grub est bien installé mais tu ne démarres pas sur la bonne entrée EFI.

Windows ne désactive par GRUB lors d'un simple démarrage, tout au plus, parfois, il l'écrase lors de certaines mises à jour.

Tu dois avoir dans le bios une entrée "Boot options priorities" et "Windows boot manager" doit être sélectionné en premier.
Debian SID (J'en ai marre de la stable il se passe rien...) Mate.
Dieu, en créant l'homme, a quelque peu surestimé ses capacités.
PascalHambourg
Contributeur
Contributeur
Messages : 679
Inscription : 05 août 2016, 20:25
Status : Hors-ligne

lol a écrit : 04 oct. 2022, 12:52 Windows ne désactive par GRUB lors d'un simple démarrage, tout au plus, parfois, il l'écrase lors de certaines mises à jour.
Si la gestion des variables d boot EFI par le firmware UEFI est buggée, tout peut arriver. Modification de l'ordre de boot, suppression d'entrées dans l'ordre de boot, suppression d'entrées de boot...

@DrPepere :
il faudrait, avant (après avoir réparé GRUB) et après avoir démarré avec Windows (sans réparer GRUB) :
1) Vérifier l'ordre et la présence de "debian" dans le menu de boot UEFI au démarrage et/ou dans les options de boot des paramètres UEFI.
2) Relever la sortie de la commande "efibootmgr" en root sous Debian ou Rescatux.
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

Bonjour à tous,

J'ai réinstallé le grub comme tu le proposais Dezix, tout est ok. Mais rebelote.

Je pense qu'effectivement il s'agit de l'ordre UEFI. Je me souviens maintenant avoir eu le même problème sur ma tour, et je l'ai réglé ainsi. Mais je pense que c'est une carte mère un peu spéciale, avec un BIOS UEFI un peu spécial. (modèle sony vaio, SVF152c29m) Voici à quoi il ressemble, ICI. Je n'ai pas trouvé l'ordre de boot UEFI, uniquement l'ordre du démarrage par support dans le bios classique.

Je ne sais pas s'il y a du chipotage possible. Je me donne deux semaines pour trouver une solution, sinon tant pis, je fermerai la fenêtre ^^.

Je ne sais pas si ce lien peut aider, par son anglais et son sujet, il ne m'est pas très accessible: ICI

Merci en tout cas du temps que vous prenez
Avatar de l’utilisateur
lol
Site Admin
Site Admin
Messages : 3952
Inscription : 04 avr. 2016, 12:11
Localisation : Madagascar
Status : Hors-ligne

Salut,

Le menu de ta capture d'écran n'est pas celui du bios mais de la récupération Windows.
Ce n'est pas dans ce menu que tu règle les options avancées de démarrages UEFI.

Ton bios devrait ressembler à ça:
Image


C'est dans ce menu que se règle l'ordre de démarrage de la machine.

Debian SID (J'en ai marre de la stable il se passe rien...) Mate.
Dieu, en créant l'homme, a quelque peu surestimé ses capacités.
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2331
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

L'accès au paramétrage du BIOS est dans cet écran :

Image

ce qui va te conduire à ce que lol montre dans son dernier message
Debian stable - XFCE
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

Rebonjour,

Je vois que j'ai oublié d'appuyer sur 'Envoyer', d'où le délai de ma réponse ^^.

Dans le menu bios, il n'y a que la priorité concernant le disque dur, l'usb, le cd et l'internet, pas les partitions. J'ai la possibilité de mettre en legacy/UEFI, chose déjà réglée.

o/
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2331
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

DrPepere a écrit : 10 oct. 2022, 08:04 il n'y a que la priorité concernant le disque dur, l'usb, le cd et l'internet
Ça me paraît normal le paramètre "Boot Device Priority" étant l'ordre des périphériques pour la recherche de quelque-chose de "bootable",
quand la recherche arrive au HDD/SSD interne en Mode UEFI si la partition ESP est trouvée => Bingo! un truc bootable !

DrPepere a écrit : 10 oct. 2022, 08:04 J'ai la possibilité de mettre en legacy/UEFI, chose déjà réglée.

Attention, si tu installes un système dans un mode et qu'ensuite tu reviens dans le BIOS pour modifier LEGACY/UEFI => Ce système ne sera plus vu/démarré.

J'ai eu fait cette erreur, j'avais Win8 donc en UEFI et je ne sais plus pour quelle raison, je ne parvenais pas à lancer mon installateur Debian (clé usb) en UEFI,
alors (me croyant fûté) j'avais passé le BIOS sur LEGACY . Là miracle la clé fonctionnait et j'avais donc pu installer Debian en "dual boot" ...
sauf que plus de Windows en LEGACY ou plus de Debian en UEFI :(( ... j'ai galéré comme cela un bon moment avant qu'on m'explique mon erreur.
Debian stable - XFCE
Avatar de l’utilisateur
piratebab
Site Admin
Site Admin
Messages : 4042
Inscription : 24 avr. 2016, 18:41
Localisation : sud ouest
Status : Hors-ligne

Une astuce que j'avais utilisé il y a bien longtemps (à l'époque ou je faisias encore du dual boot): j'avais installé grub sur le MBR de tous mes disques.
Comme ça, si un des disques avait son MBR modifié, je pouvais toujours aller dans le BIOset choisir un autre disque pour le boot. Je pouvais ainsi réparer facilement le MBR modifié à l'insu de mon plein gré.

je n'ai pas vu de réponse à la proposition de Pascal:
1) Vérifier l'ordre et la présence de "debian" dans le menu de boot UEFI au démarrage et/ou dans les options de boot des paramètres UEFI.
2) Relever la sortie de la commande "efibootmgr" en root sous Debian ou Rescatux.
PascalHambourg
Contributeur
Contributeur
Messages : 679
Inscription : 05 août 2016, 20:25
Status : Hors-ligne

piratebab a écrit : 11 oct. 2022, 16:44 j'avais installé grub sur le MBR de tous mes disques.
Comme ça, si un des disques avait son MBR modifié, je pouvais toujours aller dans le BIOset choisir un autre disque pour le boot.
C'est plus compliqué à faire avec un amorçage en mode UEFI. Et ce n'est applicable que si la machine a plusieurs disques.
Alternativement, on peut se préparer une clé USB de boot.
piratebab a écrit : 11 oct. 2022, 16:44 je n'ai pas vu de réponse à la proposition de Pascal
Non, et je n'aime pas me répéter.
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

PascalHambourg a écrit : 04 oct. 2022, 14:30 1) Vérifier l'ordre et la présence de "debian" dans le menu de boot UEFI au démarrage et/ou dans les options de boot des paramètres UEFI.
2) Relever la sortie de la commande "efibootmgr" en root sous Debian ou Rescatux.
Yop.

1) J'ai voulu aller dans les paramètres UEFI. Pour être sur, j'y suis entré par le démarrage avancé de Windows 10, comme ici. J'arrive dans les options de récupération VAIO, où il n'y a aucunes options de boot.
2) Voici ce que la commande efibootmgr renvoi
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2001,2002,2003
Boot0000* EFI USB Device (Generic Flash Disk)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
o/
PascalHambourg
Contributeur
Contributeur
Messages : 679
Inscription : 05 août 2016, 20:25
Status : Hors-ligne

Il faudrait aussi afficher le menu de boot au démarrage qui s'obtient en appuyant sur une touche variable selon la marque du firmware ou du matériel (F2, F8, F9, F12...)

Quand tu dis "plus de GRUB au démarrage", c'est Windows qui démarre tout seul ou bien rien ne démarre ?

D'après efibootmgr il n'y a aucune entrée de boot EFI enregistrée pour Debian/GRUB ni pour Windows/Microsoft Boot Manager, seulement des entrées par défaut pour les périphériques amorçables présents. Tu peux essayer la commande suivante depuis Debian :

Code : Tout sélectionner

grub-install --force-extra-removable
Puis vérifier la présence de Debian dans la sortie de efibootmgr.
Redémarrer avec Debian.
Revérifier efibootmgr et à quelle entrée correspond le numéro de BootCurrent.
Redémarrer avec Windows.
Redémarrer pour voir si GRUB se lance toujours.
Revérifier efibootmgr.
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

Un tout grand merci. Le problème est résolu. Je vais tout de même répondre à tout.
PascalHambourg a écrit : 12 oct. 2022, 20:04 Il faudrait aussi afficher le menu de boot au démarrage qui s'obtient en appuyant sur une touche variable selon la marque du firmware ou du matériel (F2, F8, F9, F12...)
Je pense qu'il n'y a pas ce menu sur ce modèle. J'ai cherché sur plusieurs endroits, notamment un manuel sur le site officiel, d'un modèle proche du mien, qui lui n'y est plus présent. J'ai vu que dans rescatux il est possible de changer l'ordre du boot.
PascalHambourg a écrit : 12 oct. 2022, 20:04Quand tu dis "plus de GRUB au démarrage", c'est Windows qui démarre tout seul ou bien rien ne démarre ?
Il démarrait tout seul, avec un cercle de point sous le logo de VAIO.

J'ai utilisé lancé la commande

Code : Tout sélectionner

grub-install --force-extra-removable
C'est quoi en fait, ce --force-extra-removable?

J'ai tout vérifier comme demandé, et Debian y est tout en haut via efibootmgr.

J'ai remarqué qu'il était marqué dans rescatux UEFI secure boot ON. Cela a-t-il quelque chose à voir?

Un tout grand merci.

o/
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2331
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

DrPepere a écrit : 13 oct. 2022, 13:53 'il n'y a pas ce menu sur ce modèle
Si ça doit être le 2èmme bouton haut/gauche de la capture :
Image
Iniciar desde un medio... (Trad : Démarrer depuis un support...

DrPepere a écrit : 13 oct. 2022, 13:53 C'est quoi en fait, ce --force-extra-removable?

Le manuel dit :

Code : Tout sélectionner

--force-extra-removable
     force aussi l'installation sur le chemin du support amovible.
     Cette option n'est disponible que sur EFI.
Je n'ai plus très bien en tête ce qu'est le chemin du support amovible
... un emplacement alternatif pour l'installation de GRUB (la question est posée dans l'installation en mode expert).

DrPepere a écrit : 13 oct. 2022, 13:53 J'ai tout vérifier comme demandé....
Tu devrais recopier la série de tests proposée par PH et y insérer les sorties complètes de chaque commande.

De la clarté et de la précision de tes réponses et des éléments fournis,
dépendent :
  1. la qualité de l'aide reçue
  2. (in)confort de ceux qui tentent de t'aider
  3. l'exploitabilité de la ressource pour de futurs lecteurs à la recherche d'information
... c'est du partage :give_rose:
Debian stable - XFCE
DrPepere
Messages : 7
Inscription : 04 oct. 2022, 07:55
Status : Hors-ligne

PascalHambourg a écrit : 12 oct. 2022, 20:04

Code : Tout sélectionner

grub-install --force-extra-removable
Puis vérifier la présence de Debian dans la sortie de efibootmgr.

Code : Tout sélectionner

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,2001,2002,2003
Boot0000* debian
Boot0001* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
PascalHambourg a écrit : 12 oct. 2022, 20:04Redémarrer avec Debian.
Revérifier efibootmgr et à quelle entrée correspond le numéro de BootCurrent.

Code : Tout sélectionner

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,2001,2002,2003
Boot0000* debian
Boot0001* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
PascalHambourg a écrit : 12 oct. 2022, 20:04Redémarrer avec Windows.
Redémarrer pour voir si GRUB se lance toujours.
Revérifier efibootmgr.

Code : Tout sélectionner

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,2001,2002,2003
Boot0000* debian
Boot0001* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Avatar de l’utilisateur
dezix
Modérateur
Modérateur
Messages : 2331
Inscription : 04 juin 2016, 14:50
Status : Hors-ligne

:good:

Merci
Debian stable - XFCE
Répondre